MacOS升级到最新版,原来安装的PHP 7.2因动态库原因无法继续使用。尝试卸载重装,brew输出如下错误提示:

[email protected]7.2 has been disabled because it is deprecated upstream!

又一次感慨阿三慢慢接管硅谷后,苹果微软等大厂的软件质量越来越不靠谱啊!无法新安装也就算了,怎么搞得原来好好的也用不了了?!!

但是某个项目仍依赖于PHP 7.2版本,没办法只能通过第三方brew源安装了:

brew tap shivammathur/php

brew install shivammathur/php/[email protected]

参考

1. How to install PHP 7.2 on macOS Big Sur using Homebrew?

2. 使用Remi源安装最新版PHP 7和PHP 8